Back to overview
Degraded

Singtel Service Interruption

Mar 20, 2026 at 11:45am UTC
Affected services
Singtel

Resolved
Mar 23, 2026 at 12:26pm UTC

Singtel has resumed service

Created
Mar 20, 2026 at 11:45am UTC

Please be informed of a Singtel service interruption, where users may experience delays in receiving or fail to receive messages. We will update once normal service resumes.