Back to overview
Degraded

Singtel service interruption

Dec 16 at 12:15am GMT+8
Affected services
Singtel

Resolved
Dec 16 at 01:59am GMT+8

[Update, as of 01:29hrs]
We have detected an issue due to increased failures affecting Singtel recipients. Upon further investigation, we have confirmed that these are genuine failures related to specific recipients using Singtel services. The issue has since been resolved

We apologise for any alarm or inconvenience this may have caused.

Created
Dec 16 at 12:15am GMT+8

00:15hrs: Please be informed of a Singtel service interruption, where users may experience delays in receiving or fail to receive messages. We will update once normal service resumes.