Back to overview
Downtime

Singtel service interruption

Jan 23, 2025 at 10:00am UTC
Affected services
Singtel

Resolved
Jan 23, 2025 at 10:05am UTC

18:00hrs: Please be informed of a Singtel service interruption, where users may experience delays in receiving messages. We will update once normal service resumes.

Created
Jan 23, 2025 at 10:00am UTC

18:00hrs: Please be informed of a Singtel service interruption, where users may experience delays in receiving messages. We will update once normal service resumes.