Back to overview
Resolved

Cloudflare service interruption

Aug 20, 2026 at 3:10am UTC
Affected services
Single send
Batch send

Resolved
Aug 27, 2026 at 1:15am UTC

The Cloudflare incident has been resolved as of 27 Aug, 9.15am. Services have been restored and your campaigns should proceed sending as per normal. We apologise for the inconvenience.

Created
Aug 20, 2026 at 3:10am UTC

Please be informed of a Cloudflare service interruption, users may experience delays / timeout issues / server errors when sending messages. We will update once normal service resumes.